Saturday, June 9

Setup Web Proxy Mikrotik




     Web Proxy dengan salah satu fungsinya yang dapat men-cache konten statik (meski kini banyak proxy yang dapat menyimpan  konten dinamis) sering dijadikan salah satu teknik untuk mempercepat koneksi internet. Tentu ini tanpa alasan, karena dengan men-cache konten statis di jaringan lokal akan meringankan beban koneksi internet dari ISP, konten yang biasanya di layani oleh ISP dengan mengambil langsung dari server kini tinggal di load dari web proxy lokal, dengan begitu akan sangat menghemat bandwith internet.

 
Mikrotik selain fungsi dasarnya sebagai RouterOS juga terdapat fitur Web Proxy di dalamnya. Dan berikut adalah tutorial untuk men-setup web-proxy pada mikrotik :
Pada tutorial ini diasumsikan setup mikrotik anda sudah beres, jika belum anda bisa lihat di sini dulu untuk setup mikrotik.
Topologi :



 
Setup Web Proxy Server pada Mikrotik
Pertama enable fitur web-proxy pada mikrotik menggunakan terminal
/ip proxy set enabled=yes port=3128 cache-administrator=Adminitrator_Jaringan max-cache-size=unlimited cache-on-disk=yes always-from-cache=yes cache-hit-dscp=4
Selanjutnya redirect semua paket web (port 80) menuju web-proxy (port 3128)
/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 in-interface=Lokal action=redirect to-ports=3128  comment=Redirect-HTTP-to-WebProxy
Yang terakhir setting mangle firewall secara terurut (jangan dibolak balik) sebagai Cache Hits (TOS) di Web Proxy Mikrotik
 
ip firewall mangle add chain=output out-interface=Lokal dscp=4 action=accept comment=Cache_Hit_Proxy
/ip firewall mangle add chain=output out-interface=Lokal dscp=4 action=mark-packet new-packet-mark=tcp-hit passthrough=no
/ip firewall mangle add chain=prerouting src-address=10.0.0.0/24 in-interface=Lokal action=mark-packet new-packet-mark=upload passthrough=no comment=WebProxyMangle
/ip firewall mangle add chain=forward src-address=10.0.0.0/24 action=mark-connection new-connection-mark=cli-conn passthrough=yes comment=WebProxyMangle
/ip firewall mangle add chain=forward in-interface=Internet connection-mark=cli-conn action=mark-packet new-packet-mark=download passthrough=no comment=WebProxyMangle
/ip firewall mangle add chain=output dst-address=10.0.0.0/24 out-interface=Lokal action=mark-packet new-packet-mark=download passthrough=no comment=WebProxyMangle

Selesai sudah setup internal web proxy mikrotik.

Setting Proxy pada Client
Selanjutnya adalah setting proxy di sisi client pada browser :
  • Firefox : “Option” > pilih tab advanced > klik “Setting” > centang “Manual Proxy Configuration” > isikan “10.0.0.1” (IP Address Mikrotik) pada HTTP Proxy dan isikan “3128” pada Port. 

  • Chrome : “Settings” > klik “Advanced Settings” > “Change Proxy Settings” > “LAN Setting” > centang “use a proxy server .....” > isikan “10.0.0.1” (IP Address Mikrotik) pada Address dan isikan “3128” pada Port.

  •  
 Untuk setting pada browser lainnya silahkan anda cari sendiri, karena pada dasarnya hampir sama :)
Jika anda ingin membuat Web Proxy tersebut Transparent agar tidak perlu repot setting pada client, silahkan lihat tutorialnya disini.

Monitoring Web Peoxy
Anda bisa memonitor berapa banyak Hit (jumlah paket yang dikirimkan dari proxy lokal ke client) dengan perintah berikut
ip proxy monitor
penulis lebih suka melihat kinerja proxy ini melalui winbox karena terasa lebih real, jika anda ingin melihat melalui winbox anda bisa melihatnya pada menu  “IP” > “Web Proxy” > “Web Proxy Seting” > klik tab “Status”
dan untuk melihat trafik Cache Hit Web Proxy, anda bisa melihatnya melalui menu “IP” > “Firewall” > klik tab “Mangle” > Double klik pada mangle yang tadi terdapat comment “Cache_Hit_Proxy” > klik tab “Statistics”


Dari gambar diatas dapat kita lihat pada detik terakhir ada 561,1 kbps konten statis yang diakses dari web-proxy lokal oleh user, dengan begitu ada penghematan bandwith 561,1 kb setiap detiknya jika di asumsikan rata2 koneksi ke web-proxy per-detik-nya 561,1 kb. Namun pada prakteknya biasanya cache hit web proxy pada router mikrotik yang penulis kelola bisa mencapai 8Mbps-10Mbps  saat user ramai, tentu ini penghematan yang sangat besar bukan ? :)
Sebagai tambahan, Jika Hardisk tempat dimana mikrotik diinstal sebagai tempat penyimpanan default cache web proxy dirasa kapasitasnya kurang memadai, anda bisa menyimpannya pada hardisk lain yang berkapasitas lebih besar, dan berikut turorialnya disini.
3 comments

3 Responses so far.

  1. wawan says:

    wah saya suka dengan blog ini... kebetulan saya mau belajar jaringan juga... saya baru mau mulai belajar mikrotik.. sran: postingin cara gabungin MR3420 dengan proxy mikrotik...

    tks

  2. "Web Proxy" adalah salah satu Fitur dari "Mikrotik RouterOS" yang fungsi utamanya adalah untuk Routing,
    Jadi jika ingin menggabungkan Web Proxy dengan MR3420,
    Untuk fungsi Routing, DHCP dan Web Proxy bisa ditaruh di Mikrotik,
    Sedangkan MR3420 difungsikan sebagai Perpanjangan LAN saja (hanya berfungsi sebagai Acess Point saja),
    jadi tinggal sambungkan saja MR3420 dengan Mikrotik dengan RJ45
    (MR3420 sebagai client dan disable fungsi Routing & DHCP pada MR3420 karena sudah dihandle oleh Mikrotik)

    Makasih :)

  3. Anonymous says:

    bermanfaat sekali artikelnya mas kebetulan saya juga lagi belajar jaringan... go indonesia :)

 
appsTrack © 2011 SpicyTricks & ThemePacific.